With version 2.9.3 of the Windows Subsystem for Linux (WSL), Microsoft introduced the possibility to run Linux containers natively on Windows without the need to install additional software. In this blog post I will use WSL Container to run an Oracle Database 26ai container image provided by Gerald Venzl.
Continue readingCategory: Administration
ExaCC: Customize ASM Diskgroup Sizes
On the 15th of May 2026, Oracle finally released the possibility to set individual percentage allocations for the ASM Diskgroups +DATACn, +RECOCn and optionally +SPRCn. This feature can be used for new and existing VM Clusters. In this blog post, I will demonstrate how to use the new feature.
Continue readingDrop database link in different schema
In this blog post, I will show different ways to drop a private database link of a different schema without connecting to this schema.
Continue readingExaCC: Database Service Events
In April 2022, Oracle released a new feature called Database Service Events for the ExaCC platform. This feature collects telemetry data of VM cluster nodes and sends a notification when a health issue is detected.
Continue readingExaCC: Single instance databases
When a new database is deployed on ExaCC, all nodes of the VM cluster are considered. But sometimes a multi-instance database is not required, for example for DEV or non-business critical databases. In this blog post, I will demonstrate how to handle this requirement with dbaascli.
Continue readingExaCC: Oracle Home deployment fails with DBAAS-60018
In this blog post, I am going to describe a strange error with OPatch while I was trying to deploy a new Oracle Home to one of our VM clusters.
Continue readingUse Oracle Linux 7.9 as WSL distribution
Since the end of January, Oracle Linux 7.9 is officially available as Linux Distribution for the Windows Subsystem for Linux (WSL). This blog post will demonstrate how to install and use it.
Continue readingDatapatch fails with ORA-27476
Today I stumbled about a very strange error while applying a release update to a 19c database. Datapatch fails with an ORA-27476 error. In this blog post, I want to show how to get rid of this error and how to identify objects in the database which may cause it.
Continue readingFormatting and filtering OCI CLI output
The default output format of the OCI commandline interface is JSON. Every available piece of information is included in the response. Especially when you use it in Shell scripts or applications, it can be difficult to extract the desired information. This blog post demonstrate the build-in filtering capabilities and the available output formats.
Continue readingConfigure Oracle Cloud Infrastructure (OCI) CLI
The Oracle Cloud can be accessed with its web console or on the command-line using the OCI CLI. In this blog post, I will show the required steps to install it and to link it with your Oracle Cloud tenant.
Continue reading